Menu

Centos6.* yum的配置与安装

2015-08-11 - Linux运维安全

今天偶然间拿下一台服务器,12核速度非常快。进去一看,郁闷,啥组件功能都木有,本来想给他安装一个openssh后门的,但是PAM丢失OpenSSL丢失。yum install 运行直接报错。。。。

算了我给他重新安装一个yum吧。。。

1.删除自带的yum

# rpm -aq|grep yum|xargs rpm -e –nodeps

2.安装rpm包

注:这里我为了方便就将所有提取出来的包放到我的VPS上供大家下载

# wget http://www.k2a.cn/Tools/centos6_yum/python-iniparse-0.3.1-2.1.el6.noarch.rpm

# rpm -ivh python-iniparse-0.3.1-2.1.el6.noarch.rpm

# wget http://www.k2a.cn/Tools/centos6_yum/yum-metadata-parser-1.1.2-16.el6.x86_64.rpm

# rpm -ivh yum-metadata-parser-1.1.2-16.el6.x86_64.rpm

# wget http://www.k2a.cn/Tools/centos6_yum/yum-3.2.29-30.el6.centos.noarch.rpm

# wget http://www.k2a.cn/Tools/centos6_yum/yum-plugin-fastestmirror-1.1.30-14.el6.noarch.rpm

# rpm -ivh yum-3.2.29-30.el6.centos.noarch.rpm yum-plugin-fastestmirror-1.1.30-14.el6.noarch.rpm

注:这一步要两个一起安装,要不会会出现如下错误:

———————————————-
yum

# rpm -ivh yum-3.2.29-30.el6.centos.noarch.rpm

warning: yum-3.2.29-30.el6.centos.noarch.rpm: Header V3 DSA signature: NOKEY, key ID e8562897

error: Failed dependencies:

yum-fastestmirror is needed by yum-3.2.29-30.el6.centos.noarch

# rpm -ivh yum-plugin-fastestmirror-1.1.30-14.el6.noarch.rpm

warning: yum-plugin-fastestmirror-1.1.30-14.el6.noarch.rpm: Header V3 DSA signature: NOKEY, key ID e8562897

error: Failed dependencies:

yum >= 3.0 is needed by yum-plugin-fastestmirror-1.1.30-14.el6.noarch

# wget http://www.k2a.cn/Tools/centos6_yum/PackageKit-yum-0.5.8-20.el6.x86_64.rpm

# rpm -ivh PackageKit-yum-0.5.8-20.el6.x86_64.rpm

# wget http://www.k2a.cn/Tools/centos6_yum/PackageKit-yum-plugin-0.5.8-20.el6.x86_64.rpm

# rpm -ivh PackageKit-yum-plugin-0.5.8-20.el6.x86_64.rpm

3.下载配置源:

# cd /etc/yum.repos.d/

# wget http://docs.linuxtone.org/soft/lemp/CentOS-Base.repo

4.测试

# yum version

Loaded plugins: fastestmirror, refresh-packagekit

Warning: RPMDB altered outside of yum.

Installed: 6/x86_64 1285:a2a18f0b8c3ca036a361579f6b22014aadfd680e

Group-Installed: yum 14:45bb88c01e2346ba8fe7ac401a053cfd42bda739

version

 

然后么上远控,安装系统后门,插猥琐一句话木马。。。。。

08085